lgob 14.08 released

11 Aug 2014

I’ve released a new version of lgob, adding support for Lua 5.2 and updating the modules to the latest library versions (GTK+ 3.12 and others).

lgob contains Lua bindings to GObject-based libraries, such as glib, gtk, gtksourceview, webkitgtk, and others, allowing quick application development by using the Lua scripting language. It is compatible with Lua 5.1, Lua 5.2, and luajit.

I’ve managed to cross-compile (by using MingW-64) lgob and gtk to Windows. A bundle with the compiled binaries can be found on the downloads page (there is one package for Lua 5.1 and one for Lua 5.2).